Building a SIEM with Suricata, Elasticsearch and Kibana

I was following a guide on how to build a SIEM How To Build A SIEM with Suricata and Elastic Stack on Ubuntu 20.04. However, I ran into an error during the installation of Filebeat (Step 4 of the tutorial).

After running the following command:

$ sudo filebeat setup

I ran into the following error:

Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to fails: invalid character 'K' looking for beginning of value. Response: Kibana server is not ready yet.

Any ideas on how to resolve this problem? Thanks in advance.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Bobby Iliev
Site Moderator
Site Moderator badge
October 14, 2022

Hi there,

Based on the output that you’ve shared it sounds like the Kibana service is not up and running yet.

Can you check the status of the service with:

systemctl start kibana.service

Also what version of Kibana did you install?



Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up