Question

By accessing page browser switches domain name by ip droplet . How to solve it ? Please please please

  • Posted December 27, 2014

My droplet configuration: Ubuntu 14.04.1 LTS / Apache/2.4.7 (Ubuntu)

My DNS configuration: *$ORIGIN mercadoallegro.com.br. $TTL 1800 mercadoallegro.com.br. IN SOA ns1.digitalocean.com. hostmaster.mercadoallegro.com.br. xxxxxxxx … www.mercadoallegro.com.br. 1800 IN CNAME mercadoallegro.com.br. * In /etc/apache2/sites-available: (two files: ) *default-ssl.conf mercadoallegro.com.conf * cat mercadoallegro.com.conf in /etc/apache2/sites-available:

*<VirtualHost *:80> ServerName mercadoallegro.com.br ServerAlias www.mercadoallegro.com.br ServerAdmin me@gmail.com DocumentRoot /var/www/html ErrorLog ${APACHE_LOG_DIR}/error.log CustomLog ${APACHE_LOG_DIR}/access.log combined </VirtualHost> * in /etc/apache2/sites-enabled (three files) : 000-default.conf.old mercadoallegro.com.conf zzz-default.conf.old (the file mercadoallegro.com.conf has the same content that before presented)

I have registered my domain in registro.br and it’s working, in other words, www.mercadoallegro.com is work but my navigator imediatly changes the domain name by ip server.

I had restarted apache2 service a lot of times.

ASK: What I did wrong? And how can I configurate my server, droplet and what else necessary to keep the domain name in navigator ??? ps.: I don’ t have cpanel or vestacp , and I am a newbie. Please help me I 'm in a couple of days in this problem and didn’t found a tutorial or help . I followed this tutorial : https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-12-04-lts but couldn’t help me And others tutorials more.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

1º) Ashamed my self!!! It was so easy and I did not see it. 2º) Thanks so much , I would be trying bite my own tail until to discover it. 3º) It work perfectly! 4º) Solved topic!

Log in to your PrestaShop dashboard and browse to Preferences -> SEO&URLs. Scroll down and you should see something like this:

Replace your IP address with your domain name (mercadoallegro.com.br, not mercadoallegro.com.br/mercadoallegro) and click on Save.