Question

Caddy not re-starting after changes in the Caddyfile

Caddy Service is working fine when the Caddyfile is empty

The moment we update the Caddyfile with my domain and email address, caddy.service sudo systemctl restart caddy fails

We have tried reset-failed and start combination and everything

/etc/caddy/Caddyfile

portexcel.com { root /home/admin/web/portexcel.com/public_html gzip tls nc@tharlines.com }

https://portexcel.com is not working

The moment we empty the Caddyfile, the caddy.service is Active, Enabled and working fine

This is where our files are and we have given access to caddy appropriately /home/admin/web/portexcel.com/public_html

We have followed the steps from here https://www.digitalocean.com/community/tutorials/how-to-host-a-website-with-caddy-on-centos-7

Only change is our root dir is different then what is given in the instructions

Please help!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@jtittle

sounds complicated to me

Anyway you can help set this up for us or we can be your client in someway :-)

@jtittle Yes Vesta CP uses NGINX and this is why I think caddy says port 80 already in use

can I uninstall vesta cp and nginx or will I have to start afresh?

I am planning multi server with a Load balancer (LB) model - Just wanted to first make it work on a single server and then wanted to replicate with one LB, one DB Server and atleast 2 Clients Server

Thereafter increase Client Servers with volume

@jtittle

Based on your input, I have tried using this - but it did not work on 2 different droplets and domains ; ProtectHome=true

I have setup my website using Vesta Control Panel and this is why my website are under /home/admin/web/sitename.com/public_html

After following all the steps, now my Vesta CP login page is also not opening https://139.59.58.199:8083/login/

Please help for both issues