Question

Can access my website through IP but not domain name [APACHE]

Hi,

I have been struggling on that one for a few days. I set up virtual hosts as per explained in various tutorial. I can access my website through the IP address but not the actual domain name.

Here is the Vhost:

<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin aloysberger@gmail.com
        ServerName aloys.dev
        ServerAlias www.aloys.dev
        DocumentRoot /var/www/aloys.dev/public_html

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

If I go to the IP address http://161.35.30.115/ it works. But neither does http://aloys.dev or http://www.aloys.dev.

I used check-host and it looks like the DNS has propagated. If I check aloys.dev it redirects me to the right IP address…

I need help here!

Thank you!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello @aloysberger

I stuck at same issue. But after some RnD

Run this below command.

sudo ufw allow ‘Apache’

and it worked for me smoothly. Hope it helps you too.

Finally worked it out.

I just got a SSL certificate and now using HTTPS over HTTP (which was the plan from the beginning).

You can get a free SSL certificate quickly at Certbot

Thanks again Alex this has been now sorted out!

Alright, so I found out that domain name .dev have issues with chrome.

I will post the answer once I found out how to make it work. But if you try to access the site from Firefox or Safari it does work.