Question

Can access my website through IP but not domain name [APACHE]

Posted April 17, 2020 474 views
Apache

Hi,

I have been struggling on that one for a few days.
I set up virtual hosts as per explained in various tutorial.
I can access my website through the IP address but not the actual domain name.

Here is the Vhost:

<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin aloysberger@gmail.com
        ServerName aloys.dev
        ServerAlias www.aloys.dev
        DocumentRoot /var/www/aloys.dev/public_html

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

If I go to the IP address http://161.35.30.115/ it works. But neither does http://aloys.dev or http://www.aloys.dev.

I used check-host and it looks like the DNS has propagated. If I check aloys.dev it redirects me to the right IP address…

I need help here!

Thank you!

edited by MattIPv4

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
6 answers

Hello, @aloysberger

Can you please check if Apache is running and also perform a restart as well? You can check if apache is running with this command:

systemctl status apache2

And also test it using netstat :

netstat -plunta | grep 80

If netstat is not installed you can install it using apt-get for Ubuntu:

sudo apt-get install net-tools

To restart Apache run:

sudo systemctl restart apache2

Everything looks good when I test it using curl or wget

domain.com!

Success! The domain.com virtual host is working!

The domain name is not loading via the browser. The DNS seems to be updated, but I’ve also tested this using a hosts file and the result was the same.

I will also double check the ownership and the permissions of the root dir for the domain and make sure that the virtual host file is enabled.

sudo a2ensite your_domain.conf

You can check the whole article here:

https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-ubuntu-18-04

Let me know how it goes.

Regards,
Alex

by Mark Drake
A "LAMP" stack is a group of open source software that is typically installed together to enable a server to host dynamic websites and web apps. This stack typically consists of the Linux operating system, the Apache web server, a MySQL database, and PHP, a dynamic content processor. This tutorial serves as a guide for installing these components on an Ubuntu 18.04 server.

Hi Alex!

Still having the same issue despite following your advice…

This is the result of the netstat commande, if it may help.

root@aloys ~# netstat -plunta | grep 80
tcp6       0      0 :::80                   :::*                    LISTEN      23160/apache2 

Also restarted/reload apache2, double checked the virtual host file is enable

sudo systemctl restart apache2
root@aloys ~# sudo a2ensite aloys.dev.conf
Site aloys.dev already enabled

Not sure I understand why you get domain.com when running the curl command?
The actual index.html doesn’t mention domain.com?

I went through the guide mentionned, also I do not wish to install PHP/MySQL for now.

I double check also these commands:

root@aloys ~# sudo a2dissite 000-default.conf

Site 000-default already disabled
root@aloys ~# sudo apache2ctl configtest

Syntax OK
root@aloys ~# 

I am running out of ideas!

Thanks for your time mate, it is much appreciated.

Here is an update!

The request doesn’t time out anymore on the domain (http://aloys.dev) but I get an error:

ERR_CONNECTION_REFUSED

That’s an improvement! The request doesn’t time out. Let’s try to find out why I get this error now.
Maybe somehow apache refuse the access through the domain name?

I’ll have a look around. Let me know if you have a clue about where that error is coming from !

And a third piece of information, if I curl the address curl www.aloys.dev I actually get the response!

curl www.aloys.dev
<html>
  <head>
    <title>Aloys.dev!</title>
  </head>
  <body>
    <h1>Success! The aloys.dev virtual host is working!</h1>
  </body>
</html>

Alright, so I found out that domain name .dev have issues with chrome.

I will post the answer once I found out how to make it work.
But if you try to access the site from Firefox or Safari it does work.

Show answer This answer has been marked as resolved by aloysberger.
Submit an Answer