Question

Can I still get the WordPress One-Click Ubuntu 16.04 with MySQL 5.7?

Posted May 10, 2020 398 views
WordPress

I’m having problems using the WordPress one-click droplet with Ubuntu 18.04 with MySQL 8.0.29, so I want to create another droplet using the previous Ubuntu 16.04 and mysql 5.7. This is what I was using in the past and it worked well, where can I find the option to install this version of the droplet.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @mhweb,

Don’t worry about Ubuntu 18.04 as it is better than 16.04, We should always use the new version, Ubuntu 20.04 LTS is out, you should go and set up your droplet using.

Can you explain what problem you’re having? You didn’t mention any problem. If you’re worried, Don’t worry, Let me know I’ll help you to set up your droplet with Ubuntu 20.04.

Go here: https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-on-ubuntu-20-04-quickstart

Use this configuration for your server:

 server {
        listen 80;
        root /var/www/public_html;
        index index.php index.html index.htm;
        server_name domain.com;

        location / {
             #try_files $uri $uri/ =404;
             try_files $uri $uri/ /index.php?$args;
        }

        location ~* \.php$ {
              fastcgi_pass   unix:/var/run/php/php7.4-fpm.sock;
              fastcgi_index  index.php;
              fastcgi_param  SCRIPT_FILENAME   $document_root$fastcgi_script_name;
              include        fastcgi_params;
        }
}
by Erika Heidi
In this quickstart guide, we’ll install a LAMP stack on an Ubuntu 20.04 server.
  • I’ve been using the wordpress one-click droplet with ubuntu 16.04 and mysql 5.7, but the server started to age and I have having memory problems.

    So, I created a new droplet, but digitalocean upgraded its wordpress droplet with with ubuntu 18.04 and mysql 8.0.19, and when I transferred the site, the memory problems went away, but now I noticing high cpu usage, the cpu goes and up down, and it’s because of a mysql process taking the CPU time.

    Here are more details about the problem: https://www.digitalocean.com/community/questions/how-to-configure-mysql-to-prevent-processor-spikes

    So, right now, i’m thinking that if i had the same configuration as before, everything will go back to normal.

    • Hi @mhweb,

      It also depends on your system hardware resources. If you have big data and traffic on your website, probably you should choose sufficient hardware resources.

      If you want, then you can do everything manually.

      • I would agree to that suggestion, if I didn’t know that the current requirements are more than enough, since transferred the site again to another droplet with identical hardware, and I’m no longer seeing problems with mysql and low memory usage. (However, apache is now acting up.)

        Correction, the mysql is not having issues, because I haven’t tried to optimize the tablets again, which is something that I’m sure it’ll bring the problem back.

        It’s so weird how these droplets are behaving.

  • The above configuration is for Nginx server, I posted by mistake, sorry for that, Here is a configuration for the Apache Server:

    # domain: example.com
    # public: /var/www/html/example.com/public_html/
    
    <VirtualHost *:80>
      # Admin email, Server Name (domain name), and any aliases
      ServerAdmin webmaster@example.com
      ServerName  example.com
      ServerAlias www.example.com
    
      # Index file and Document Root (where the public files are located)
      DirectoryIndex index.html index.php
      DocumentRoot /var/www/html/example.com/public_html
      <Directory /var/www/html/example.com/public_html>
          Options Indexes FollowSymLinks
          AllowOverride All
          Require all granted
      </Directory>
    
      # Log file locations
      LogLevel warn
      ErrorLog  /var/www/html/example.com/log/error.log
      CustomLog /var/www/html/example.com/log/access.log combined
    </VirtualHost>
    
Submit an Answer