Setup a WHM, CPanel and WordPress website on a DO droplet.
Accessed the WHM via the link provided after making a connection via ssh

After changing the host name I am no longer able to reach the WHM, CPanel or Wordpress from my IP address.

I tested the functionality of all of these services by making a remote connection to a Windows 10 desktop that I have setup on the west coast and verified that I can reach the admin consoles on all of the services.

There is no firewall setup in the DO control panel and when I ssh into the server I ran ufw status and it does not recognize the command.

I used the marketplace WHM to setup this droplet and I am wondering if there could be something like fail2ban or some other IP blocker running on this droplet and how I can find it.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Hello, @GhostInTheMachines

Do you receive any error messages when trying to access WHM using the IP address? Also make sure to access it like this:

https://IPaddr:2087

You will receive a warning message about the certificcate but this is expected.

You should have iptables running on the server, but you can also install CSF (Config Server Firewall) using this mini tutorial:

https://www.digitalocean.com/community/questions/how-to-install-and-configure-config-server-firewall-csf-on-centos

Regards,
Alex

  • Hello Alex,

    I tried accessing WHM using IP:Port and the IP is replaced with the FQDN:port which should mean that the reverse dns PTR record is working but the error message “This site can’t be reached” is what I am getting.

    Last night I ran iptables -L which I think means that there are no firewalls which is expected since I haven’t set them up yet.

    ACCEPT tcp – anywhere anywhere multiport dports smtp,urd,submission owner GID match mailman
    ACCEPT tcp – anywhere anywhere multiport dports smtp,urd,submission owner GID match mail
    ACCEPT tcp – anywhere localhost multiport dports smtp,urd,submission owner UID match cpanel
    ACCEPT tcp – anywhere anywhere multiport dports smtp,urd,submission owner UID match root

I believe you can simply log into you WHM panel using server IPaddress/whm or ipaddress:2086 or ipaddress:2087

Edit: make sure your own IP address is not banned from the firewall somehow or the port is not blocked. You can install a temporary VPN and try logging in again. Just verify your own IP adress from https://whatismyip.live

I should add that it is working this morning but I would sure like to know how this is being temporarily blocked and what is initiating it.

Submit an Answer