I have a very old droplet and I am trying to sort out the kernel management but everything is failing. When I power off the droplet and go to the kernel option, the “change” button is greyed out - I can not select any options.
So, how can I change my kernel?

$ uname -r
3.13.0-32-generic

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.5 LTS
Release:    18.04
Codename:   bionic

grub has all of the correct details but I can not see how to get my droplet to use grub.

# update-grub
Sourcing file `/etc/default/grub'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-156-generic
Found initrd image: /boot/initrd.img-4.15.0-156-generic
Found linux image: /boot/vmlinuz-4.15.0-154-generic
Found initrd image: /boot/initrd.img-4.15.0-154-generic
Found linux image: /boot/vmlinuz-3.13.0-71-generic
Found initrd image: /boot/initrd.img-3.13.0-71-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
done

How can I sort this mess out please?

1 comment
  • Did you manage to solve the problem? I have the exact same issue. I noticed it because ip tables stopped working after a reboot:

    me@server-upgrade-test:~$ sudo ufw status
    ERROR: problem running iptables: modprobe: FATAL: Module ip_tables not found in directory /lib/modules/3.13.0-71-generic
    iptables v1.6.1: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.
    

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hello @paul841204 ,

Check this page, explains in a simple way the process to follow.

The first point in Table of contents is important Make a backup :)

Hope helps you,
Sergio Turpín

I asked support, and this is the answer I got:

Hi there,

Many thanks for reaching out to us and we’ll be happy to help!

I suspect the issue may be somehow related to the externally managed kernel that you had on the older Droplet you created a Snapshot from. Would you be open to the idea of migrating to a new Droplet? You can create a new Droplet and then just copy files over to a new Droplet using rsync or a similar tool:

https://www.digitalocean.com/community/tutorials/how-to-copy-files-with-rsync-over-ssh

If you do want to continue trying to use your current Droplet, it might be worth trying to move to an internally managed kernel by using our grub loader kernel as explained here:

https://docs.digitalocean.com/products/droplets/how-to/kernel/

From there you can try updating the kernel to see if it resolves the issues you’re seeing. For what it’s worth, my primary recommendation is to migrate, as the legacy kernel management your old base Droplet is using may cause further problems in the future. That being said, we’re committed to supporting you either way and we’ll be happy to continue to troubleshoot any issues you have. Please let us know if you have any other questions or if there’s anything we can do to help.

by Bulat Khamitov
In this tutorial we'll use Rsync to copy files over SSH.
  • Regarding the disabled Change button, this is what they came back with:

    The actual issue behind the Change Kernel button remaining grey/disabled, is a weird bug at play that we’re working on correcting. In order to work around it, you will need to actually start typing in the box to conduct a search, and then select a kernel, which should allow you to change the kernel. If you just click in the box and select a kernel, that causes the button to remain greyed out. So this would mean manually typing in full kernel name for the button to be enabled, instead of opening the drop-down and selecting it.