Can only access my wordpress site using IP address

August 26, 2014 3.9k views

Can only get to my Wordpress site using the ip address. When I put in the site name all I get is "This webpage is not available" and on the chrome tab I see the previous hosts icon (hostgator, who were incidentally a nightmare to move away from). I have signed in to hostgator weeks ago to manage the nameservers and have checked again they are set to...
ns1.digitalocean.com
ns2.digitalocean.com
ns3.digitalocean.com

Have checked whois and it reports...
Name Server: ns1.digitalocean.com
Name Server: ns2.digitalocean.com
Name Server: ns3.digitalocean.com

What else might the problem be?

2 Answers

After you change the nameservers of you domain to DigitalOcean you have to configure the DNS for the domain name, see here for more info:
https://www.digitalocean.com/community/tutorials/how-to-set-up-a-host-name-with-digitalocean

by Etel Sverdlov
This article walks you through setting up the DNS for your site. The tutorial includes steps to set up an A records, point your nameservers, and provides some information about MX records.
  • Yes I have followed the guide and my setup was correct anyway. I have pinged my domain no problem. When I type the domain into the browser I'm getting "This webpage is not available"!

    I believe my DO setup is correct. It must be a setting on the Wordpress side??

  • I find that I can get to my website using the ip or the domain name. But if I prepend WWW to the domain name I get webpage not found.

    Baffled and fed up

Do a DNS lookup for the A record:

dig A yourwebsite.com +short

This should print the IP address of your Droplet.

For the WWW portion to work create a CNAME record for your domain in the DNS section of DO's control panel:

CNAME Record

Have another answer? Share your knowledge.