Question

Can send but not receive email (CentOS, Postfix)

Posted August 6, 2013 62.8k views
I followed the instructions here to set up PostFix and I now have mail being sent from my website working just fine. https://www.digitalocean.com/community/articles/how-to-install-postfix-on-centos-6 However I cannot receive emails. I added an A and MX record for the mail server a few days ago. I would like to either set up multiple user accounts to run from outlook (need passwords on each etc. so may be more complex) or just have everything get forwarded to free gmail accounts. In postfix main.cf I have: virtual_alias_maps = hash:/etc/postfix/virtual in /etc/postfix/virtual I have a line for each intended email address and where it should forward e.g.: me@mydomain.com me@gmail.com Then I did this: # postmap /etc/postfix/virtual # service postfix reload But I get nothing, any ideas? Thanks

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
26 answers
Gone through the whole process, still cannot receive email. Emails are sent, but cannot receive. Here are my MX records:

A @ 198.199.125.224
CNAME www @
CNAME * @
NS NS1.DIGITALOCEAN.COM.
NS NS2.DIGITALOCEAN.COM.
NS NS3.DIGITALOCEAN.COM.

Followed Etel Sverdlov's tutorial on setting up Postfix & Cyrus on Centos 6.
Check postfix's error logs - do you see any errors? Do you have a firewall running? Is port 25 open on your droplet? Are you sure you set up the MX/A records properly?
I have iptables configured as the digitalocean guide suggests and just checked the rules are there:

ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:110
ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:995

I have the following DNS records:

A @ my.domain.ip.address
A mail.mydomain.com. my.domain.ip.address
MX 1 mail.mydomain.com.


Nothing in postfix error log
I wonder if the mail is going somewhere and I just dont know where, as it used to bounce but the last few times it didn't
Add this rule:

-A INPUT -p tcp -m tcp --dport 22 -j ACCEPT

Try sending an email now - does that work?
added that but nothing
i think he meant to put
-A INPUT -p tcp -m tcp --dport 25 -j ACCEPT
port 22 is for ssh, 25 is smtp.
still nothing

"Delivery to the following recipients has been delayed." is bounce message
Sorry, my bad. I meant port 25 instead of 22. Run this command locally:

telnet yourip 25

Are you able to connect?
Previous 1 2 3 Next