Question

Can send but not receive email, just using basic console mail like sendmail and mutt

I have: MX 1 mail.tanglewoodforest.tk. mail.tanglewoodforest.tk. IN A 192.241.200.53 @ IN A 192.241.200.53 @ TXT “v=spf1 ip4:192.241.200.53 -all”

  • CNAME @

But when mail comes to me I see possibly resets in my tcpdump: 10:28:12.001021 IP mail-yh0-f43.google.com.48272 > tanglewoodforest.tk.smtp: Flags [S], seq 3986132201, win 42900, options [mss 1430,sackOK,TS val 4050176638 ecr 0,nop,wscale 6], length 0 10:28:12.001079 IP tanglewoodforest.tk.smtp > mail-yh0-f43.google.com.48272: Flags [R.], seq 0, ack 3986132202, win 0, length 0 10:30:09.455246 IP mail-yh0-f49.google.com.51782 > tanglewoodforest.tk.smtp: Flags [S], seq 2481880713, win 42900, options [mss 1430,sackOK,TS val 2250336 ecr 0,nop,wscale 6], length 0 10:30:09.455290 IP tanglewoodforest.tk.smtp > mail-yh0-f49.google.com.51782: Flags [R.], seq 0, ack 2481880714, win 0, length 0

I used to have no problem with this, but since I made a new droplet, I’ve never got it working again. I can send out from the droplet using Mutt just fine.

DISTRIB_ID=Ubuntu DISTRIB_RELEASE=12.10 DISTRIB_CODENAME=quantal DISTRIB_DESCRIPTION=“Ubuntu 12.10” NAME=“Ubuntu” VERSION=“12.10, Quantal Quetzal” ID=ubuntu ID_LIKE=debian PRETTY_NAME=“Ubuntu quantal (12.10)” VERSION_ID=“12.10”


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

+=---------=+ <br>| Fixed It! | <br>+=---------=+ <br> <br>It’s all in “/etc/mail/sendmail.mc” <br> <br>Sendmail is setup to only accept mail from localhost. <br> <br>Changing: DAEMON_OPTIONS(Family=inet, Name=MTA-v4, Addr=127.0.0.1, Port=smtp')dnl <br>To: DAEMON_OPTIONS(Family=inet, Name=MTA-v4, Port=smtp’)dnl <br> <br>The “Addr=127.0.0.1” parameter means to only accept email from localhost. <br> <br>But what I hadn’t done was the instructions at the top of the sendmail.mc file which is to recomile/remake the sendmail.cf file with: <br>make -C /etc/mail <br> <br>And now it works!

Now i’m just trying to figure out how to get my original /etc/mail/* config files back to stock, since apt-get purge/autoremove/autoclean and then reinstalling didn’t help.

Host files good, DNS good, pointer good. Though when i run a sendmailconfig i do get these errors: <br>Creating /etc/mail/submit.cf… <br>Informational: confCR_FILE file empty: /etc/mail/relay-domains <br>Informational: confCT_FILE file empty: /etc/mail/trusted-users <br>Updating /etc/mail/access… <br>makemap: error opening type hash map /etc/mail/access.new.db: Permission denied <br>Reload the running sendmail now with the new configuration? [Y] <br>Reloading sendmail … <br>makemap: error opening type hash map /etc/mail/access.new.db: Permission denied <br>chown: cannot access /etc/mail/access.new.db': No such file or directory <br>chmod: cannot access /etc/mail/access.new.db’: No such file or directory <br>mv: cannot stat `/etc/mail/access.new.db’: No such file or directory <br>make: *** [/etc/mail/access.db] Error 1 <br> <br>