Can send but not receive email, just using basic console mail like sendmail and mutt

  • Posted April 15, 2014

I have: MX 1 IN A @ IN A @ TXT “v=spf1 ip4: -all”

  • CNAME @

But when mail comes to me I see possibly resets in my tcpdump: 10:28:12.001021 IP > Flags [S], seq 3986132201, win 42900, options [mss 1430,sackOK,TS val 4050176638 ecr 0,nop,wscale 6], length 0 10:28:12.001079 IP > Flags [R.], seq 0, ack 3986132202, win 0, length 0 10:30:09.455246 IP > Flags [S], seq 2481880713, win 42900, options [mss 1430,sackOK,TS val 2250336 ecr 0,nop,wscale 6], length 0 10:30:09.455290 IP > Flags [R.], seq 0, ack 2481880714, win 0, length 0

I used to have no problem with this, but since I made a new droplet, I’ve never got it working again. I can send out from the droplet using Mutt just fine.

DISTRIB_ID=Ubuntu DISTRIB_RELEASE=12.10 DISTRIB_CODENAME=quantal DISTRIB_DESCRIPTION=“Ubuntu 12.10” NAME=“Ubuntu” VERSION=“12.10, Quantal Quetzal” ID=ubuntu ID_LIKE=debian PRETTY_NAME=“Ubuntu quantal (12.10)” VERSION_ID=“12.10”


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

+=---------=+ <br>| Fixed It! | <br>+=---------=+ <br> <br>It’s all in “/etc/mail/” <br> <br>Sendmail is setup to only accept mail from localhost. <br> <br>Changing: DAEMON_OPTIONS(Family=inet, Name=MTA-v4, Addr=, Port=smtp')dnl <br>To: DAEMON_OPTIONS(Family=inet, Name=MTA-v4, Port=smtp’)dnl <br> <br>The “Addr=” parameter means to only accept email from localhost. <br> <br>But what I hadn’t done was the instructions at the top of the file which is to recomile/remake the file with: <br>make -C /etc/mail <br> <br>And now it works!

Now i’m just trying to figure out how to get my original /etc/mail/* config files back to stock, since apt-get purge/autoremove/autoclean and then reinstalling didn’t help.

Host files good, DNS good, pointer good. Though when i run a sendmailconfig i do get these errors: <br>Creating /etc/mail/… <br>Informational: confCR_FILE file empty: /etc/mail/relay-domains <br>Informational: confCT_FILE file empty: /etc/mail/trusted-users <br>Updating /etc/mail/access… <br>makemap: error opening type hash map /etc/mail/ Permission denied <br>Reload the running sendmail now with the new configuration? [Y] <br>Reloading sendmail … <br>makemap: error opening type hash map /etc/mail/ Permission denied <br>chown: cannot access /etc/mail/': No such file or directory <br>chmod: cannot access /etc/mail/’: No such file or directory <br>mv: cannot stat `/etc/mail/’: No such file or directory <br>make: *** [/etc/mail/access.db] Error 1 <br> <br>

Yep, no firewalls, no iptables. All wide open and listening on port 25 for

I’m not able to connect to port 25 on your droplet – is your mailserver running? Make sure it’s listening on the public interface. You can check what interface it’s listening on by running <pre>sudo netstat -plutn</pre>Also make sure that your firewall isn’t blocking connections to port 25. <br> <br>Finally, try removing the wildcard CNAME record and adding rules manually as needed as it might be conflicting with the mail record.