Can someone assist me with installing powerdns?

June 26, 2017 484 views
DNS

I've went through every power dns install tutorial here all of which have ended in errors.
Goal: install powerdns on 2 vps one for pvns1 one for pvns2
These nameservers need to be able to be used anywhere as a offshore nameserver.

Can someone help me out"? 23hrs in

4 Answers
OffshoreHost June 26, 2017
Accepted Answer

I should add, I will be using whmcs plugin of solutedns to assign these.

Hi @OffshoreHost

You say that every installation ended in error - can you supply those errors, since that will help us trying to figure it out.
Also link to whatever tutorials, so we know what you've tried to follow.

I'm guessing you have already read and followed this tutorial?
https://www.digitalocean.com/community/tutorial_series/how-to-configure-dns-servers-with-powerdns-on-ubuntu-14-04

Yes, that was my first shot. So with that I got it completely setup with power admin and all. Issue I had was with the DB. Requirements that's not the word, basically what mysql depended on wasn't compatible with the ubuntu version. Something had been nulled. So on to try to update ubuntu. It would not upgrade due to that. I researched a solution for this for a couple hours and it seemed like i was running 50 commands and possible installing a lot of un needed stuff as none of the ideas were working. So i killed it and attempted on centos 5. I got about 3/4 through that install & the directions were not real detailed. Said the mac address was not as expected. I couldn't locate anything that was not talking about someone setting up a local dns server. So i destroyed this one and found what looked to be the solution. virtuozo or whatever install script. Got to step 3 i believe and upon entering the command provided returned command not found. Tried breaking it down into single commands, it took the commands but did not execute the install. The download did save to the vps but it wouldn't execute. I checked the permissions and they were all right. wasn't much research on this material on this one. I tried to do the same on centos 6. same result. I cussed my little dog out over here & had a smoke outside. :) lol

I apologize for not providing more details as I was confident in finding a solution on my own. Sadly that was not the case.

  • @OffshoreHost
    It's always good with a smoke before you do something you might regret :-)
    Well, I totally get that you're a little tired and this now, but I would actually recommend that you try again, but try with Ubuntu 16.04 and MariaDB 10.2
    And whenever you hit a problem, then don't stress too much - try to solve it yourself, but don't just insert whatever commands, because then it would be better to pause and ask here (or another forum) while supplying commands and errors.

I'll do this. Thanks man, you know how it is. Get aggravated & ready to say f it. lol
I was getting these commands from other forums by googling my error codes. I've also went back and redone stuff like this to have no errors the next time & it be something I a. overlooked b. entered wrong. I'll update

  • @OffshoreHost And remember to hit the Reply link or use the @ to notify people - otherwise we won't get a notification and we might miss your comment.

Have another answer? Share your knowledge.