vee6
By:
vee6

can't access droplet through ssh nor through console

May 5, 2017 153 views
DigitalOcean

I created a Fedora droplet and added my machine's public SSH Key (that I happen to use for other services and which seems to work well with other services) to it before creation. After creation I cannot access it via ssh, I get the following message:

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

I tried to connect to it via console but I get prompted for login and password. I think I should have received them by email or something like that, but I received no email whatsoever. what to do?

1 Answer
jtittle1 May 5, 2017
Accepted Answer

@vee6

If you added a public key to your DigitalOcean account and selected that public key during the deployment of your Droplet, you won't receive a root password as password authentication is disabled when SSH keys are used.

You would need to login and pass the private key associated with the public key you provided.

ssh root@droplet_ip -i /path/to/privatekey

The above works on MacOS and Linux, though if you're using Windows and PuTTy, you'd need to set the path to your private key in the configuration settings for putty.

  • works, thanks. I was missing the root@ part. I tried without it or with the username mentioned in the public key at the end as I assumed that would be created.

    • @vee6

      No problem, happy to help!

      The root user is always the user that you'll use to first login with when it comes to most Linux distros. Once you login with root, you can create additional users and setup SSH keys for them as well, though it all has to be done after the fact.

      Your local user won't and can't be created on login.

Have another answer? Share your knowledge.