Can't access puTTy and filezilla

Posted July 30, 2019 2.6k views

Hello there
I can’t access my droplet using puTTy or filezilla ,I didn’t touch anything i just created the droplet and facing that issue , how can i fix it?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
5 answers

You can check if your home IP address is not blocked on the droplet for some reason. I don’t know if you’re using CSF or just iptables. You can whitelist your IP address via the following command:

iptables -A INPUT -s IPaddr-j ACCEPT

Make sure to save the iptables to make the change permanent.


  • root@ubuntu:~# iptables -A INPUT -s IPaddr-j ACCEPT
    Bad argument `ACCEPT’

    • You can follow this article for all the iptables commands:

      You can use these commands to allow incoming ssh access:

      sudo iptables -A INPUT -p tcp -s –dport 22 -m conntrack –ctstate NEW,ESTABLISHED -j ACCEPT
      sudo iptables -A OUTPUT -p tcp –sport 22 -m conntrack –ctstate ESTABLISHED -j ACCEPT

      Make sure to change the IP address with the IP of your home network.


      by Mitchell Anicas
      Iptables is a software firewall for Linux distributions. This cheat sheet-style guide provides a quick reference to iptables commands that will create firewall rules that are useful in common, everyday scenarios. This includes iptables examples of allowing and blocking various services by port, network interface, and source IP address.
      • Thanks Alex
        But nothing really helped me :(

        • You can ssh to the droplet using your mobile data and examine the /var/log/messages and /var/log/secure for the entries matching your IP address

          cat /var/log/messages | grep IP
          cat /var/log/secure | grep IP

          In this way we will gain some further information. Looking forward to your reply.


          • Can’t find the directories anyway I’m down to give you the vps info to check it out since im running out of mobile data if you would like to talk somewhere else discord / twitter


Can you please let us know the exact output you see in puTTy and FileZilla when you try to connect? This will help us to track down the issue.


  • Hey Alex

    for filezilla :
    Error: Connection timed out after 20 seconds of inactivity
    Error: Could not connect to server

    for puTTy :
    Network error:Connection timed out

    • Have you tried rebooting the server? The ssh service might be offline or just not responsive.

      Can you perform a traceroute and see if you’re able to connect to the server? You can check for packet loss as well (feel free to paste the output here as well)

      Run traceroute on Windows
      Open the Start menu.
      Click Run.
      To open the command line interface, type cmd and then click OK.
      At the command line prompt, type: For IPv4 - >


      For IPv6 - >

      tracert -6

      Press Enter.

      Linux / Mac

      traceroute IPaddr or domain

      Let me know how it goes.


      • 1 5 ms 4 ms 5 ms
        2 4 ms 12 ms 4 ms
        3 5 ms 29 ms 7 ms
        4 * * * Request timed out.
        5 80 ms 72 ms 69 ms
        6 * * * Request timed out.
        7 100 ms 97 ms 92 ms []
        8 81 ms 70 ms 72 ms
        9 * * * Request timed out.
        10 * * * Request timed out.
        11 * * * Request timed out.

        I’m getting this

        • It seems like you’re not able to get to your droplet. As mentioned have you tried rebooting it to see if it will make a difference?


Sorry for the delay. Are you still experiencing the issue?


Do you have access to the droplet using alternative network? I know you mentioned you can access it via your mobile phone’s network.

Can you also let us know the OS of the server and if you’ve installed any additional software on it that can prevent block you?