Can't access web server connection timed out

Posted August 28, 2019 5.4k views
NginxUbuntuDigitalOceanDNSPHP Frameworks

Good Morning, I have an issue. I can connect to Digital Ocean droplets through putty, it work. But, when i tried to open my web host through chrome, its always said connection error. Yesterday, I open my host or my dns, it show nginx welcome pages. I just tried my laravel project in my subdomain, it work for for several minutes, then several minutes later it can’t be reached, so do my host. What happened? Sorry, for my broken english.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

Hi @greenrelfishy,

What you are describing sounds just like a DNS propagation. Usually DNS propagation can take up to 48 hours but in reality it should be much quicker than that.

Since you posted your question, 14 hours have passed and everything should be working properly if you haven’t configured your DNS in a wrong way.

Can you please confirm if you are still experiencing the said issues?

Kind regards,
Kalin D.

Hi, I have this issue too. I want to open remote termianl via VSC and work on my droplet there, because the Console is a bit clunky. After I made the connection to my droplet on VSC adding username and IP, it never connects and I receive this message:

Could not establish connection to “o.Development.server.digitalocean”. The operation timed out.

Yesterday, it was working fine, it connected quickly asking my UNIX password. But now I have this error -any issues from DO end? Why I receive the message above?

Many thanks in advance,