Question

Can't Bring Network Up & Running After Pi-hole Configuration

On my VPS, I was trying configure OpenVPN + PiHole. During the process I had to restart the networking. Afterwards the networking got broken and locked me out. Now I can only access my Droplet from the console in the Digital Ocean control panel.

Once I’m in, I can see that everything works as expected(Apache, SSH, Gitlab, etc.) but since my networking is down, nothing can be accessed from the outside.

I tracked down the root cause of the problem to broken eth0 settings. I don’t believe it’s a firewall issue. My IP and Netmask settings were broken. They were falsely changed by Pi-Hole. I tried fixing them but I still get the same error message I got before trying to fix my settings when I execute systemctl status network:

https://postimg.cc/RqRRhCk5

How should I proceed?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello, all

I would like to say that OpenVPN + Pihole is available as one-click install droplet in our Marketplace. You can find more information here:

https://marketplace.digitalocean.com/apps/openvpn-pihole#getting-started

You can also check out this short demo of configuring and setting everything up from an Android device.

API Creation

curl -X POST -H 'Content-Type: application/json' \
     -H 'Authorization: Bearer '$TOKEN'' -d \
    '{"name":"choose_a_name","region":"sfo2","size":"s-2vcpu-4gb","image":"pihole-18-04"}' \
    "https://api.digitalocean.com/v2/droplets"

Regards, Alex

The issue is handled after contacting Digital Ocean support staff and them handing me the correct configuration for my eth0.

For anyone trying to configure Pi-Hole or OpenVPN, better back-up your eth0 configuration before hand!