Question

Can't communicate with Google Apps email addresses

I am having a big problem with email on my server which is running Ubuntu and VestaCP.

I can send and receive emails fine unless I try sending an email to an address which is setup on Google Apps email. I also cannot receive emails from these addresses either. I can send and receive fine to @gmail.com emails however, its only those domains that are setup on google apps.

The log file says this everytime:

2016-09-28 12:26:21 H=mail-io0-f169.google.com [209.85.223.169] sender verify fail for <mike@adzdesigns.com>: Unrouteable address
2016-09-28 12:26:21 H=mail-io0-f169.google.com [209.85.223.169] F=<mike@adzdesigns.com> rejected RCPT <mike@webba.co.uk>: Sender verify failed

any help would be greatly appreciated as I have spent all morning trying to figure it out.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

I have solved it…

Delete any domains using external mail service like Google Apps under the “mail” tab in VestaCP or in etc/exim4/domains on server.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I have now worked this out and fixed it! Hopefully if someone else having the same problem this will help them…

Simply delete the domains under the “mail” section in VestaCP that are using an external email service, or do it on the server under etc/exim4/domains

I have actually narrowed this down a little more now…

Email only does not work if I try to send from a mailbox on my server to a email that is setup on Google Apps. Likewise if I try to send an email from the Google Apps email address to my server it also will not work. All other emails working fine…

Any ideas what this could be? DNS settings?

I have in the past, to overcome such things, just set up the server to use SMTP, and then used a Google Apps account as the SMTP server. That solved all issues, as the mail then gets sent from Googles own servers…no more need for authenticating my server.

Here is a tutorial I used for that, but there are probably some plugins for doing the same thing. The tutorial is for AWS, but it worked just fine in my Ubuntu 14.04 droplet (and should work for 16.04)

http://living.fuyuko.net/make-php-mail-work-aws-ec2-ubuntu/