Can't communicate with Google Apps email addresses

September 28, 2016 147 views
Email Ubuntu

I am having a big problem with email on my server which is running Ubuntu and VestaCP.

I can send and receive emails fine unless I try sending an email to an address which is setup on Google Apps email. I also cannot receive emails from these addresses either. I can send and receive fine to @gmail.com emails however, its only those domains that are setup on google apps.

The log file says this everytime:

2016-09-28 12:26:21 H=mail-io0-f169.google.com [] sender verify fail for <mike@adzdesigns.com>: Unrouteable address
2016-09-28 12:26:21 H=mail-io0-f169.google.com [] F=<mike@adzdesigns.com> rejected RCPT <mike@webba.co.uk>: Sender verify failed

any help would be greatly appreciated as I have spent all morning trying to figure it out.

4 Answers
mike166 September 28, 2016
Accepted Answer

I have solved it..

Delete any domains using external mail service like Google Apps under the "mail" tab in VestaCP or in etc/exim4/domains on server.

I have in the past, to overcome such things, just set up the server to use SMTP, and then used a Google Apps account as the SMTP server.
That solved all issues, as the mail then gets sent from Googles own servers..no more need for authenticating my server.

Here is a tutorial I used for that, but there are probably some plugins for doing the same thing. The tutorial is for AWS, but it worked just fine in my Ubuntu 14.04 droplet (and should work for 16.04)


  • thankyou I will give that a try, will that then send the mail through Google on all the domains on my server? Or does each need to be setup seperately? Do you know if there is a limit on the number of emails that can be sent daily also?

I have actually narrowed this down a little more now...

Email only does not work if I try to send from a mailbox on my server to a email that is setup on Google Apps. Likewise if I try to send an email from the Google Apps email address to my server it also will not work. All other emails working fine..

Any ideas what this could be? DNS settings?

I have now worked this out and fixed it! Hopefully if someone else having the same problem this will help them...

Simply delete the domains under the "mail" section in VestaCP that are using an external email service, or do it on the server under etc/exim4/domains

Have another answer? Share your knowledge.