j.maes97
By:
j.maes97

Can't connect Jetpack or IFTTT to Wordpress on Ubuntu 16.04 LAMP

May 31, 2016 1.1k views
LAMP Stack PHP WordPress Networking Ubuntu 16.04

Dear community,

I've migrated my Multisite Network from an Nginx server to a LAMP Stack (PHP7) with Ubuntu 16.04, via the export/import function. I've managed to fix most issues, but I'm still having issues with Jetpack integration and connecting to IFTTT.

Info and debug logs
Jetpack debug:

site_inaccessible
Foutdetails: The Jetpack server was unable to communicate with your site [HTTP 500]. Ask your web host if they allow connections from WordPress.com. If you need further assistance, contact Jetpack Support: http://jetpack.com/support/

```It seems like your site can't connect with Jetpack.
SELF:
Array
(
[headers] => Array
(
[server] => nginx
[date] => Tue, 31 May 2016 18:33:21 GMT
[content-type] => text/plain;charset=utf-8
[connection] => close
[expires] => Wed, 11 Jan 1984 05:00:00 GMT
[cache-control] => no-cache, must-revalidate, max-age=60
[pragma] => no-cache
[x-hacker] => Jetpack Test
[x-ac] => 3.ams _dfw
[strict-transport-security] => max-age=15552000
)

[body] => {"error":"Can not resolve domain nameservers","error_description":"We were unable to resolve the nameservers for your domain. It is likely that you have recently registered your domain name. It takes several hours for new or transferred domain names to start working, so please come check back later."}
[response] => Array
    (
        [code] => 400
        [message] => Bad Request
    )

[cookies] => Array
    (
    )

[filename] => 

)```

As you can see, this debug logs says Nginx, while my sites are all running on Apache now. I've deleted Jetpack, re-installed, but to no avail.

A similar issue occurs when I'm trying to connect any website in my network to an IFTTT service. "Live channel fields value is not a valid Wordpress url"

What I've tried
Server reboots
Disabling all plugins and themes
Re-installing Jetpack

I've done some research and people with similar issues seem to have an issue with their XML-RPC Server .php file. I have this .php file on my websites and it seems to run normally: server accepts POST requests only.

I haven't set up a firewall, so that shouldn't be an issue.

Is there anyone that might have an idea on how to resolve these issues? I assume they're linked.

Thanks in advance. :)

Kind Regards,

2 Answers

The key issue seems to be this:

[body] => {"error":"Can not resolve domain nameservers","error_description":"We were unable to resolve the nameservers for your domain. It is likely that you have recently registered your domain name. It takes several hours for new or transferred domain names to start working, so please come check back later."}

Have you already pointed your domain to the new server (the one that is configured in wp-admin)? Jetpack needs to be able to reach your server from outside using the name it's set up with. If you're in the process of a migration this might not be the case until the domain has been redirected to your droplet.

  • Hi Ryan,

    Thanks for responding! :)

    I've noticed that too but it's a bit weird. I've handled my nameservers / DNS settings yesterday and propagating shouldn't take longer than 30 mins. Still doesn't work and all my domain settings are correct and pointed to the right droplet.

what is the apache2 error log saying?
I also got an error [500] and figured out in the error.log that the php-xml parser was missing. Installed the package and worked...

Have another answer? Share your knowledge.