rstel89
By:
rstel89

Can't connect to droplet via SFTP with FileZilla

October 1, 2015 7.2k views
Getting Started Deployment DigitalOcean Linux Commands

I am trying to connect to my new droplet using FileZilla. I followed the instructions here
https://www.digitalocean.com/community/tutorials/how-to-use-filezilla-to-transfer-and-manage-files-securely-on-your-vps

to setup FileZilla. However I receive the following errors:
Error: Network error: Connection refused
Error: Could not connect to server

After searching google I found that I may have to create a new user. So i followed the following tutorial to create a new user:

https://www.digitalocean.com/community/tutorials/how-to-add-and-delete-users-on-ubuntu-12-04-and-centos-6

However that did not solve the problem either. I am at a lost for words. I am not sure what to do. i am trying to transfer a project that I was developing locally to the server. I am used to just ftp'ing the files over. Any advice would be greatly appreciated.
(note: I tried to login as root and as the newly created user and still received the error)

1 comment
  • Sorry about that after doing my digging I realized I was using port 2 not 22! Thanks guys. Anyone else who stumbles upon this those two guides worked for me.

Be the first one to answer this question.