Question

Can't Connect to MySQL Server on IPAddress (10061)

I have already a sistem loaded on digital ocean using a mysql database and is working perfectly, but the problem is that i can’t connect using mysqlworkbench to the database and i getting the error Can’t Connect to MySQL Server on IPAddress (10061)

Im new using this services of digital ocean, so i don’t know what is wrong on my settings to access the database. (which is actualy working for the system).

I don’t know what to configure over the mysqlworkbench to access the database:

1)Shall I use a tcp/ip or tcp/ip / ssh ??

Thanks for your support Rgds


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Need to reconfigure the my-sql server. i used “mysql-installer-community-5.7.20.0” to reconfigure the server. and now it is working well. If “MySQL57” will looks in windows services. then it will work properly. Installer community will restart the server or you can also restart manually by below flow

Step-1-> Open Run or type Run in task-bar search of window and press Enter Step-2->Type “services.msc” in Run and press Enter Step-3->Search “MySQL57” in windows services Step-4->If server is not running then Right click on mouse button and click on Start.

Before doing this need to reconfigure the mySql server for removing “Can’t Connect to MySQL Server on IPAddress (10061)”

If “MySQL57” is not looking on windows services then you should need to reconfigure again.if it will shows in services then it will work properly.

By default MySQL will listen for connections only from the local host. To enable remote connections like the one used by mysqlworkbench you will need to modify your /etc/my.cnf and change

bind-address 127.0.0.1

to

bind-address 0.0.0.0

or simply comment out the line completely. Once this is done, restart MySQL with the command

service mysql restart

and you should be able to make your connection.

This comment has been deleted