Question

Can't connect to ownCloud through davfs2 or Nautilus

I recently installed an ownCloud one-click application on a $10/mo droplet. When I try to access my owncloud files with the browser client, or with an Android client (cirrus), everything seems to work fine. I see two folders, Documents and Photos. But when I use Nautilus (davs://myowncloud/remote.php/dav) or mount the owncloud storage with davfs2, I see 7 folders: addressbooks, calendars, comments, files, etc. files/ is completely empty with davfs, and when I try to open it in Nautilus, I get an error “This location could not be displayed” and “Sorry, could not display all the contents of “files”: HTTP Error: Method Not Allowed”.

So I checked the apache access logs:

xxx.xxx.9.90 - admin [05/Apr/2016:18:48:03 -0400] "PROPFIND /remote.php/dav HTTP/1.1" 207 1857 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:03 -0400] "PROPFIND /remote.php/dav HTTP/1.1" 207 5180 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:05 -0400] "PROPFIND /remote.php/dav/files HTTP/1.1" 207 1863 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:05 -0400] "PROPFIND /remote.php/dav/files/ HTTP/1.1" 405 1240 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:07 -0400] "PROPFIND /remote.php/dav/files HTTP/1.1" 207 1863 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:07 -0400] "PROPFIND /remote.php/dav HTTP/1.1" 207 1857 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:08 -0400] "PROPFIND /remote.php/dav HTTP/1.1" 207 5180 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:11 -0400] "PROPFIND /remote.php/dav/principals HTTP/1.1" 207 1868 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:11 -0400] "PROPFIND /remote.php/dav/principals/ HTTP/1.1" 207 3311 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:13 -0400] "PROPFIND /remote.php/dav/principals/users HTTP/1.1" 207 1874 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:13 -0400] "PROPFIND /remote.php/dav/principals/users/ HTTP/1.1" 405 1240 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:15 -0400] "PROPFIND /remote.php/dav/principals HTTP/1.1" 207 1868 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:15 -0400] "PROPFIND /remote.php/dav HTTP/1.1" 207 1857 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:15 -0400] "PROPFIND /remote.php/dav/files HTTP/1.1" 207 1863 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:15 -0400] "PROPFIND /remote.php/dav HTTP/1.1" 207 5180 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:18 -0400] "PROPFIND /remote.php/dav/calendars HTTP/1.1" 207 1867 "-" "gvfs/1.22.2"
xxx.xxx.9.90 - admin [05/Apr/2016:18:48:19 -0400] "PROPFIND /remote.php/dav/calendars/ HTTP/1.1" 405 1240 "-" "gvfs/1.22.2"

It looks like most PROPFIND requests to URIs ending in a slash are returning 405 Method Not Allowed, except certain top-level directories like prinicipals/. All equivalent PROPRFINDs to non-slash URIs result in 207 Multi-Status, which I’m assuming is the expected response.

Any ideas what’s going on here?

Subscribe
Share

This solution did not work for me. I don’t have an httpd.conf, and apache2.conf and owncloud.conf don’t have the problem referenced in the solution.

you may want to take a look at http://serverfault.com/questions/206052/how-do-i-enable-http-dav-in-apache . I haven’t worked with the ownCloud one-click install, but the URL link seems to have the same exact symptoms as your access log snippet.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I figured out how to get around the issue. I had to connect to /remote.php/webdav instead of /remote.php/dav ( /dav had been suggested in the official owncloud tutorial).