I am trying to connect with Workbench MySQL from my laptop to 1 click droplet with workbench but I cannot get a connection.
I tried both the Droplet IP as well as the floating IP. I am not using (installed) SSH for simplicity. I am using standard TCP and tried as root and other users but no luck.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Is this a Managed Database on Digital Ocean
Digital Ocean does not have any help regarding connection from workbench to Managed Database. This is very annoying

  • Hi, do you find solution I have the same problem SSL Error connection to connect from navicat or workbench to managed digital ocean mysql database

    Thx

Hello,

I believe that your MySQL port is closed via your firewall so that’s why you are not able to access it remotely.

What you could try doing is allowing your IP address and then try to connect again. You could do that with the following command:

sudo ufw allow from your.home.ip.here

Then check the status:

 sudo ufw status

Hope that this helps!
Regards,
Bobby

Hi,
mysql server is listening to 127.0.0.1 by default.
so try to use this as MySQLHost

Submit an Answer