Can't generate Solidus configuration files

I have been following instructions on to install Solidus. Everything has worked but the terminal command hangs when I run bin/rails generate solidus:install. I ran as root user. Could this be a port or a compatibility issue between psych and rails? The start of the error reads:a

/usr/share/rvm/gems/ruby-2.7.2/gems/psych-4.0.4/lib/psych/visitors/to_ruby.rb:430:in `visit_Psych_Nodes_Alias’: Cannot load database configuration: Unknown alias: default (Psych::BadAlias)

I have removed the droplet but will try reinstall.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Bobby Iliev
Site Moderator
Site Moderator badge
September 3, 2022

Hi there,

It sounds like that the database details that were provided during the bin/rails generate solidus:install command were not correct.

What type of database are you using? For example, if you are using Postgres, do you have Postgres installed on your server:



Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

card icon
Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Sign up
card icon
Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We’d like to help.

Learn more
card icon
Become a contributor

You get paid; we donate to tech nonprofits.

Learn more
Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow – whether you’re running one virtual machine or ten thousand.

Learn more ->
DigitalOcean Cloud Control Panel