Patlamm
By:
Patlamm

Can't get https to work

July 24, 2017 147 views
Apache WordPress Ubuntu 16.04

Just can't get this to work. I have a Wordpress installation on LAMP stack. I'm also using Cloudflare CDN. I have the certificates from Let's encrypt. I'm able to access the site from http no problem with a Virtual Host configuration (non-ssl).

I've made a new configuration to be able to access my site with SSL, but when trying to go to the https address, i'm getting redirected to http.

I'm pretty sure that the ports are open in UFW.

Right now, I have three virtual host configuration, one for cloud.atakama-studio.conf, I will want this one to be secure, but i've started with the main site for now, atakama-studio.conf, and i've done a atakama-studio-ssl.conf. I don't mind having everything in the same vhost configuration for atakama-studio, but i'm not sure I want all the site to be secure, maybe only the form page...

Here's my VirtualHost configuration:
*:443 www.atakama-studio.ca (/etc/apache2/sites-enabled/atakama-studio-ssl.conf:3)
*:80 is a NameVirtualHost
default server www.atakama-studio.ca (/etc/apache2/sites-enabled/atakama-studio.conf:1)
port 80 namevhost www.atakama-studio.ca (/etc/apache2/sites-enabled/atakama-studio.conf:1)
alias atakama-studio.ca
port 80 namevhost cloud.atakama-studio.ca (/etc/apache2/sites-enabled/cloud.atakama-studio.conf:1)

Here's my ports.conf
pastebin.com/u3FNjT4R

here's my atakama-studio.conf :
pastebin.com/PfZwvcmc

here's my atakama-studio-ssl.conf :
pastebin.com/LkSjEMmp

I have both config enabled.

Please someone, help me !

4 Answers

Hi @Patlamm

Your HTTPS is working fine, but it is redirecting to HTTP.
My guess is that it's one of your WordPress security plugins that is causing this.

Make sure that you've set the following two WordPress settings on this page:
http://www.atakama-studio.ca/wp-admin/options-general.php

WordPress Address (URL) = https://www.atakama-studio.ca
Site Address (URL) = https://www.atakama-studio.ca

Thanks. I've made the change. I also enabled full SSL in Cloudflare. I can now access my admin section with a green HTTPS and the index page of my site, but It broke my other pages. I tried to save the modification on permalinks. I've enabled SSL for the front-end of the site in iThemes Security. Something is still missing somewhere...

I've changed AllowOverride to All on my SSL config file and it's now working. Yeaaaa

Where can I find a recent exemple of https configuration for apache 2.4 with the right SSLCipherSuite, etc ?

Have another answer? Share your knowledge.