Question

Can't get permanent links in wordpress to work - 404 error

Posted March 4, 2013 6.7k views
Just transferred my wordpress blog to the new server ubuntu 10.4 with the LEMP setup. But I can't get my permanent links to work, getting 404 error. Already tried the following and nothing seems to work 1. Enabled apache2 for mod_Rewrite 2. Regenerate the .htaccess file in WordPress by going to Settings -> Permalinks -> and clicking to "Save Changes" Database was setup correctly. Able to login to admin and saw all my pages got transferred

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
4 answers
Pastebin your .htaccess file. And you say you "enabled apache2 for mod_rewrite". Did you restart apache?
Hi Jason,

I just figured it out and it is now working. The problem was due to Apache2 AllowOverride Not Enabled. I had to change that to ALL Enabled.

Thanks for the response. Very much appreciated.
Why is there apache on a LEMP install image?
Could be a reverse proxy setup? i.e. NGINX -> Apache - that's actually pretty common, especially if you just need a better way to serve static content and don't want to go through the entire process of setting up NGINX to serve all virtual hosts.
Submit an Answer