Question

Can't get to the ftp site- connection timing out

Posted October 1, 2014 4.2k views

A vendor of our has given us access to their products and photos but the address which they have verified works I cannot get to.
ftp://images.krollcorp.com/
All I keep getting is:
Problem loading page
The connection has timed out

The server at images.krollcorp.com is taking too long to respond.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

i tried from Filezilla but it won’t connect either. Kroll says it must be something on my end but I have tried through Chrome and Foxfire and took my firewall down and still nothing. Any help would be greatly appreciated as I cannot load products until this is solved.
I am using windows 7, microsoft essentials, and foxfire latest version.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

1 answer

Testing the URL, I get a prompt for a user/pass, so it’s working. I’d hop on the command prompt, and run “nslookup images.krollcorp.com”

If that fails, you may need to run “ipconfig /flushdns”

If it still fails, this appears to fall outside hosting issues. Sorry about that.

Submit an Answer