Question

Can't Install Or Update Wordpress Plugins

  • Posted September 12, 2014

I’ve checked around the web quite a bit for a solution to this, but despite a lot of people having the issue, as well as there being answers, nothing seems to work for me. For whatever reason, I can’t install, or update plugins. When I attempt to, I’m met with an ftp login on the Wordpress page, which from my understanding means that my persmission or owner is wrong.

I’ve tried:

-Setting my settings on wp-content to 777 (temporarily of course) -sudo chown -R myuser:www-data /var/www/anightinburlington.com/public_html/*

Neither of those worked, and I’m not sure what’s wrong. I’ll be here all day, speakers loud, email notifications ready - if anyone could help, I’d be more than thankful!

Subscribe
Share

So I double-checked, and triple-checked my settings, and all permission / owners / etc are proper. I added my custom port (which I know works due to ftp) to the wp-config file, and I followed the rest of the tutorial / comments to the detail. I even tried deleting my keys, and making new ones - nothing works.

I’m going insane trying to figure this out. Is there anything else that could stop this from working? My server block location settings? I’m completely out of ideas, and I absolutely need this fixed. I’ve spent an entire day without luck, and I’m fried / frustrated.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi there,

Hopefully this isn’t still and issue for you, but I recently came across the same problem…

In my case my permissions where correct.

The fix for me is to add a line into wp-config.php, adding the following fixed it all. define(‘FS_METHOD’, ‘direct’);

Hope that helps someone in the future.

This comment has been deleted

I had the same problem, I was selecting FTPS (I was pretty sure it was correct), so I tried SSH2 without authentication keys and it worked.

Holy crap I solved it. I would still like some helping sorting out WHY this is the issue, but I fixed it.

For whatever reason, my setup is NOT letting me create a user with an empty password. I tried making a new user, with no password, same issue. I then gave my user a password, and applied it to the wp-config for the ssh connection, and everything works. Whenever I try to create a user on a LEMP stack, (Ubuntu 14.04), I get:

authentication token manipulation error.

If anyone else is getting that error, and has done everything else I mentioned in that thread, that’s likely the cause. Simply set a password for your created user upon creation, or update it via:

sudo passwd YOUR_USERNAME

Be sure to then update your wp-config file to use that password, rather than the ‘’ for the empty password.

So I read up on the situation more, and I indeed had more steps to take. I had to add my new wp-user to the list of ssh users in the config (done), and had to change the port in wp-config to my new port (done). Despite reading every single comment on the page, restarting nginx php5-fpm, and ssh, I still get the error that the keys are inccorect:

Public and Private keys incorrect for wp-user

The only thing I can think of, is that I got the below error when creating my new user, and setting an empty password:

authentication token manipulation error

The “user” I created is just wp-user, does this user need to be the same name as the user I log into wordpress with? (this wasn’t specified anywhere in the tutorial)

Is that normal when you create a user and don’t assign a password? I’m completely stumped at this point, and am at a dead end - any ideas?

According to your tag I think you’re using nginx as webserver. Did you try the following ?

sudo chown -R nginx:nginx /var/www/anightinburlington.com/public_html/

This tutorial should walk you through all of the steps:

How To Configure Secure Updates and Installations in WordPress on Ubuntu

Let me know if you still have issues after running through that tutorial :)