Question

Can't install packages on Ubuntu 14.10

I tried installing php5-curl package on my VPS, but apt-get gave me this error message:

# apt-get install php5-curl

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  php5-cli php5-common php5-fpm php5-gd php5-readline
Suggested packages:
  php-pear php5-user-cache
The following NEW packages will be installed:
  php5-curl
The following packages will be upgraded:
  php5-cli php5-common php5-fpm php5-gd php5-readline
5 upgraded, 1 newly installed, 0 to remove and 156 not upgraded.
Need to get 4,956 kB of archives.
After this operation, 154 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
  php5-readline php5-cli php5-fpm php5-gd php5-common php5-curl
Install these packages without verification? [y/N] y
Err http://mirrors.digitalocean.com/ubuntu/ utopic-updates/main php5-readline amd64 5.5.12+dfsg-2ubuntu4.6
  404  Not Found [IP: 95.85.0.50 80]

... (more sources)

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/p/php5/php5-curl_5.5.12+dfsg-2ubuntu4.6_amd64.deb  404  Not Found [IP: 91.189.91.24 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

None of apt-get update or --fix-missing seems to fix this. What can I do with this issue?

Also it does the same for package curl, even when I run

# curl --version
curl 7.37.1 (x86_64-pc-linux-gnu) libcurl/7.37.1 OpenSSL/1.0.1f zlib/1.2.8 libidn/1.28 librtmp/2.3
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp smtp smtps telnet tftp
Features: AsynchDNS GSS-Negotiate IDN IPv6 Largefile NTLM NTLM_WB SSL libz TLS-SRP
Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Being Ubuntu 14.10 is now EOL (end of life), you will want to try and update the distribution. Many bugs and security fixes will no longer get placed in the EOL repositories, so you would be leaving your server potentially vulnerable. You can find more information on updating to a newer distribution via this article.

That all said, if you wish to continue using an EOL distribution, you would need to change the /etcv/apt/sorurces.list file to use the hostname mirrors.digitalocean.com/ubuntu-old instead of using the current hostname.

So if the entry was:

deb http://mirrors.digitalocean.com/ubuntu trusty universe

You would want to change that over to:

deb http://mirrors.digitalocean.com/ubuntu-old trusty universe

Hope it helps! Jason Colyer DigitalOcean Platform Support Lead

I guess 14.10 is out of support. Many packages is not available anymore. Seems only solution is upgrade OS to stable release with sudo do-release-upgrade

Am I right?