nuborian
By:
nuborian

Can't install sails.js

January 4, 2017 167 views
DigitalOcean Ubuntu 16.04

Hey,

I've setup a new "one-click" droplet with ubuntu and node (tried both that are available at the moment)

For any reason, i am not able to install sails.js - all other npm packages are not problem...

@*:~# sudo npm -g install sails
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated node-uuid@1.4.7: use uuid module instead
npm WARN deprecated native-or-bluebird@1.1.2: 'native-or-bluebird' is deprecated. Please use 'any-promise' instead.

Any idea? I don't really know what these errors are telling me ...

Help would be great !

Best, Nico

4 Answers

Those are warnings, whats the full output?

That's the full output - I can't see anymore ? :/

@nuborian

Have you tried running npm update? If not, try running that and running the install again.

If the issue persists, or if only some of the warnings persist, try installing the packages noted and upgrading the one that needs to be.

i.e.

npm install -g minimatch@3.0.2 \
&& npm install -g uuid \
&& npm install -g any-promise

Thanks for your help - sadly that doesn't work, too :/

Have another answer? Share your knowledge.