Can't install Wordpress themes - FTP Error

Hey all,

Newbie to development here.

I’m getting this error when I try to install a theme from Wordpress: “Failed to connect to FTP Server”.

It’s asking me for my hostname, username, and password which I put in (checked to see if they are correct from Transmit 2 and SSH).

What I find weird is that Transmit connects to SFTP through port 22 (which I thought was dedicated to SSH) and when I try to connect through port 21 (which Wordpress tries to do) it fails.

If it helps – I installed Wordpress using the Ubuntu 14.04 guide. Another thing: I think I installed my original droplet with the LAMP stack, but then installed it again with the LAMP Stack Guide for Ubuntu 14.04, don’t know if that would cause these sorts of problems.

Any help would be much appreciated! Thanks in advance.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

You don’t need FTP for installing a theme. Open wp-config.php file into Wordpress root installation folder and add

define('FS_METHOD', 'direct');

It should works.

chown -R www-data:www-data /var/www find /var/www/ -type d -exec chmod 755 {} ; find /var/www/ -type f -exec chmod 644 {} ;

Worked for me toooo! Thanks!

I can confirm that the following command worked (for me)

chown -R www-data:www-data /var/www
find /var/www/ -type d -exec chmod 755 {} \;
find /var/www/ -type f -exec chmod 644 {} \;