Question

Can't launch Rails app with Nginx and passenger

  • Posted on September 12, 2013
  • abachukAsked by abachuk

Installed nginx, passenger 4.0.17, node, rails 4 and ruby 2, git and all gems.

nginx config:

server {
        listen 80;
        server_name  162.243.1.111;
	root /home/abachuk/myapp/public;
	passenger_enabled on;
	rails_env production;
}
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      1828/nginx ```

what else is missing?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I was able to make it work. Here are details for those who have same issues <br>http://alexbachuk.com/launch-rails-4-application-with-passenger-and-nginx/

Do you have any symbolic links in <code>/home/abachuk/myapp/public</code>?

yes. I also tried to launch with one click install. Rails 3 works fine. But rails 4 doesn’t work anywhere. Not sure why. I guess I missed something. I created 3 droplets and tried to launch the app in 3 different ways. Unicorn, passenger, apache. Nothing works. I would appreciate any help. Thanks.