Question

Can't load IP address or domain, but SSH and Ping is working.

I am running a LAMP stack on Ubuntu 16.04. On it I have three wordpress instances installed, one is on a subdomain, and the other two are on TLDs. Earlier today everything was working fine.

Just now when I go to one of the domains it does not load and then gives me this error: ERR_CONNECTION_TIMED_OUT

I have tried restarting Apache and turning my droplet on and off, still it does not work. I am able to SFTP into the IP using Filezilla, I can SSH into the IP on a command line, I ran a ping test on the IP and it came back fine. I am only on the 1GB Memory 1 Core Processor, is it possible that’s an issue? My usage of the site seems to be minimal, I just installed the wordpress instances and only had a bare bones site on one of them, the rest were blank.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@jtittle @hansen

I just restarted apache to fix the connection being refused. I have absolutely no idea at what point it was fixed, but a tremendous thank you to you both for helping me with this!!

@jtittle I checked the ports.conf and did the grep command, but it was only in the ports.conf. it looks identical to your file too. I changed it to 0.0.0.0 to see if that would do anything and it didn’t.

Another note, is now my error has changed, it’s no longer timing out when I try to visit the domain/IP, not it just says connection is being refused.

@habbywall

I deployed a fresh Ubuntu 16.04 Droplet to check the configuration for Apache as it tends to change from time to time.

The Listen directive should be defined in /etc/apache2/ports.conf, which should look like:

Listen 80

<IfModule ssl_module>
        Listen 443
</IfModule>

<IfModule mod_gnutls.c>
        Listen 443
</IfModule>

If any of those are setup with an IP, or if any Listen directive is setup with an IP elsewhere, then that may be the issue. Only specifying the port leads to listening on both IPv4 and IPv6 IP’s. If you specify an IP address, then it will only listen on the protocol for that IP.

You can run:

grep "Listen" /etc/apache2/*.conf

To see if any files, other than ports.conf, have a Listen directive setup. If they did, check that file and that should lead to us getting this fixed.