Question

can't log in via ssh all of a sudden (was working before)

Posted January 7, 2018 2k views
UbuntuDeployment

I set up an SSH key for my droplet 9 months ago when I started it, and have been logging in to my server from terminal using the root user with no problem. But today it suddenly stopped working. When I typed in the command:

ssh root@[ip.address]

It says “Permission denied (publickey)”.

I don’t know what went wrong. I don’t remember changing anything. But it just suddenly stopped working. Any ideas what the problem could be?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Have you recently deleted any files off your computer, you may have accidentally deleted your key. You can always just create a new one though if you SSH into your server using the password that you originally got then it should be all good

I recently experienced the same (and fixed it).
Reason: human error :)

I was fiddling with docker, and accidentally changed the ownership of my .ssh folder to docker:docker (I thought i was smart by symbolically linking /root/.ssh to /home/docker/.ssh)

Anyways, after setting the appropriate permissions/ownership of the .ssh-folder everything worked again. Hope this helps.

Submit an Answer