trowland
By:
trowland

Can't log into new Debian 9 Droplet via SSH

June 19, 2017 366 views
Deployment Debian

I created a new Debian 9 droplet and I can't seem to log in. The command I'm using is

ssh -p 22 root@<IPv4-address>

followed by the password that was emailed to me by digital ocean. I have tried using the web based console to login and that doesn't work either. I'm wondering if the issue is on DigitalOcean's end rather than mine because the droplet is brand new and logging in using the password they sent me doesn't work moments after the droplets creation. Also there are no SSH keys associated with my account, so that shouldn't be an issue.

Anyways, if you guys could offer any suggestions that would be great. Thanks.

2 Answers

@trowland

There was an issue with the Debian 9 image and not setting the password correctly, though this has been fixed as of this reply, so I would destroy the existing Droplet and deploy a new Droplet with the fixed image and see if you're able to log in.

If you're still not able to log in, please tag me and I'll pass it upstream so we can get this fixed!

Depending on the terminal emulator you're using, special characters in passwords may not behave (this is an issue I've seen with Putty before, where @'s and bangs in passphrases make it unable to log in interactively). My advice would be to set up ssh keys and use those instead; you really should be using them anyway as it's far easier, and more importantly, it's much more secure.

Have another answer? Share your knowledge.