Question

Can't login to droplet after reset root password

Hi. I use droplet from DO and now i take that problem:

When I try to connect to my droplet after root password reset I can’t login after initial password change:

I enter the password sent by e-mail I enter new password for root twice System disconnected without any errors.

When I try to connect again my new password don’t work but temporary password for email works fine. And the situation is repeated.

What can you do in this situation? Support ignoring my questions for more than three hours.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Because you used simply password, try add a similar password such as the password supplied by the system. I have solved this problem with this method, and after changed successfully, you can change again with new simple password

@EOnegin

I just spun up a new CentOS 7 Droplet, received the root password, and logged in using:

ssh root@IP

Where IP = Droplet Public IP.

After entering in the password once more and changing it at the prompt, I was brought to the normal prompt as expected.

I’m using Terminal on my MacBook Pro, though I also tested this on Windows 10 using PuTTy w/o any issues on my end.

Have you tried simply destroying the current Droplet or recreating it? I know that doesn’t help too much, though I can’t see any issues popping up when testing on a new droplet.