Question

Can't login with the console even after password reset. Actually it has never worked

After I had followed the guide for installing openVPN I tried to log into my webserver and realized it was not connecting so I unwound all of my changes from the document:

https://www.digitalocean.com/community/tutorials/how-to-set-up-an-openvpn-server-on-ubuntu-16-04

and uninstalled openvpn. Now I cannot connect to my Ubuntu server at all.

Not sure if this made a difference but since part of the install was opening ufw for OPENSSH I denied it…

maybe that’s why I cant ssh in… Still I should be able to use the console…But that has never worked for me from DO


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@chrisberberich

If you used an SSH key to setup your Droplet, you won’t have a root password, thus won’t be able to login through console. If you setup ufw to deny SSH access, you won’t be able to access SSH by terminal either, so you would effectively be locked out.

If the Droplet isn’t in-use right now, there’s not critical data on it, and you’re locked out, the best thing to do at this point would be to simply destroy the droplet and instead of actually hitting destroy, look below and simply choose the re-image option by selecting the OS you prefer.

In a few seconds, the VPS will be re-imaged with the OS of your choice and you’ll be able to log back in.