Question

Can't make vhosts to work :(

  • Posted August 27, 2013

I am successfully using WebMin to a ubuntu server I have, but I cannot make vhosts to work in a new CentOS server. If I have only the default server installed in /var/www/html when I try to see my server using the IP address, I see the /var/www/html/index.html (that’s correct). When I create a new vhost, although I setup directory and servername, the whole server (even with ip address) looks to this folder. I tried to find what it is but I cant. I noticed that the option " New file under virtual servers directory" is missing from the add new vhost form. Any idea?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

@Pablo: Since he’s using Webmin, editing any config files manually would only make things worse. <br> <br>Try asking in the official webmin forums (might want to search there if a thread already exists before creating a new one): <br> <br>http://sourceforge.net/p/webadmin/discussion/600155

Have you tried following the steps outlined, here: <a href=“https://www.digitalocean.com/community/articles/how-to-set-up-apache-virtual-hosts-on-ubuntu-12-04-lts”>How to Set Up Apache Virtual Hosts on Ubuntu 12.04 LTS</a>?