Question

Can't make vhosts to work :(

Posted August 27, 2013 1.7k views
I am successfully using WebMin to a ubuntu server I have, but I cannot make vhosts to work in a new CentOS server. If I have only the default server installed in /var/www/html when I try to see my server using the IP address, I see the /var/www/html/index.html (that's correct). When I create a new vhost, although I setup directory and servername, the whole server (even with ip address) looks to this folder. I tried to find what it is but I cant. I noticed that the option " New file under virtual servers directory" is missing from the add new vhost form. Any idea?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers
Have you tried following the steps outlined, here: How to Set Up Apache Virtual Hosts on Ubuntu 12.04 LTS?
by Etel Sverdlov
This tutorial shows you how to set up a new directory, how to grant the correct permissions, how to add content to a new page, how to turn on virtual hosting, and how to, if needed, set up local hosts. Virtual Hosts are used to run more than one domain off of a single IP address and allows you to run multiple sites off of a single DigitalOcean droplet. This tutorial describes how to set up virtual hosts with Apache.
@Pablo: Since he's using Webmin, editing any config files manually would only make things worse.

Try asking in the official webmin forums (might want to search there if a thread already exists before creating a new one):

http://sourceforge.net/p/webadmin/discussion/600155
Submit an Answer