kylegoetz
By:
kylegoetz

Can't ping droplet, VNC console stuck at "ENGINE Bus STARTED", etc.

April 6, 2017 771 views
Getting Started Miscellaneous Networking System Tools Backups Ubuntu

Booted up droplet. Can't ping, 10+ minutes later. Console output is:

DOROOT: clean, ... files, ... blocks

Waiting for network configuration...

Waiting up to 60 more seconds for network configuration...

Booting system without full network configuration...

Starting nginx: nginx.

No make, you'll have to rebuild your databases by hand :(

* Not configured, not started

* Starting Mail Transport Agent (MTA) sendmail [OK]

[Thu Apr 06...] [warn] The Alias directive in ...apache.conf

at line 3 will probably never match because it overlaps an earlier Alias.

apache2: Could not reliably determine the server's fully qualified domain name,

using 127.0.0.1 for ServerName

(98)Address already in use: make_sock: could not bind to address [::]:80

(98)... 0.0.0.0:80

no listening sockets available, shutting down

Unable to open logs

Action 'start' failed.

The Apache error log may have more information.

* Starting web server apache2 [fail]

[...] ENGINE Bus STARTING

... ENGINE Started monitor thread 'Autoreloader'.

... ENGINE Started monitor thread '_TimeoutMonitor'.

... ENGINE Serving on 127.0.0.1:8081

... ENGINE Bus STARTED

I can't seem to ping at all.

Is there a way to create a new droplet, pull my critical data off this droplet (like mount the droplet as a drive in the new one, and then just get rid of the old droplet?

This droplet is three years old, been running Ubuntu 12, and I suspect trying to update to 16 and following some apt-get commands is what did it in, but really not sure.

Otherwise, I'll just restore from my 8 day old backup, which was running fine, but is missing a couple days of data I'd rather not lose (but nothing super important, so it's a 95% acceptable alternative).

Thanks.

2 Answers

It also appears since I created this droplet three years ago, a new "boot in recovery mode" feature has been added. I just created a new droplet from backup and see this. However, the hosed droplet doesn't have this in the "Power" section. It just has power off and power cycle buttons.

Have another answer? Share your knowledge.