can't ping my droplet from local machine

Hello out there! I setup a base droplet, with a basic nodejs application, which I could access via ssh and browser.

I then updated the droplet for more RAM to: 2 GB Memory / 1 AMD vCPU / 25 GB Disk / FRA1 - Ubuntu 20.04 (LTS) x64

Since then I can’t access the droplet remotely. I tried the following:

  1. ping floating IP and ping IPV4
  2. ssh floating IP and ping IPV4
  3. access running node application http://FLOATING_IP:PORT via browser they all timeout.

If I try the above directly from the host(droplet) terminal, it works.

any clues?

PS. I tried powering off/on the droplet and delete/reassigning a floating IP without success. ufw status is also inactive

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @jiannis,

In cases like this there is one solution only where you can access your Droplet and that is the recovery console. The Recovery Console provides out-of-band access and is available regardless of your network settings. It emulates the access you would have if you were sitting down with a keyboard and monitor attached to the actual server. You can use this feature to log in and revert bad settings to regain normal access.

You can read more about that here:

Basically, what you need to do is go to your Control Panel click on your Droplet, go to the Access page and Launch the Console.

If this doesn’t work as well, there might be an issue with the Droplet itself not being able to boot. In this case, I’ll recommend contacting DigitalOcean’s support. They should be able to help you out in such cases:

Hope that helps! - KFSys.