Question

Can't receive emails from Wordpress/Gravity Form

  • Posted August 30, 2013

Hi. I have Gravity Forms installed on my website abcbend.com which uses Wordpress. However, none of the form results are being sent to my email address ‘valerie@abcbend.com’ or any gmail address. Does it have to do with Google SMTP or any SMTP issue?

In the forums, I saw that it might help if I install an SMTP Wordpress plugin so I did. But I need the following info. I asked Support but they said they can’t help me. Can anyone please point me to the right direction? Specifically, I need to fill these fields out:

Host SMTP Secure None SSL TLS Port SMTP Authentication No Yes Username Password

Thanks in advance.

Subscribe
Share

When setting up a notification the From Email field must contain an email address that includes your website’s domain name


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello all,

What I could suggest here is using an SMTP plugin for your WordPress site.

That way you will be able to specify an SMTP server with authentication which your emails would be going through. You could for example use Gmail’s SMTP settings. This would drastically increase the delivery rate of your emails as well compared to using plain PHP mail.

I’ve been using this plugin for a while now and it works very well: Easy WP SMTP

Hope that this helps! Regards, Alex

Did you set up a SMTP mailserver on your droplet? You usually don’t need to do that, just install an MTA and use php’s mail() function (you can configure Wordpress to use that instead of SMTP). <br> <br>Postfix usually works perfectly out of the box: <br> <br><pre>DEBIAN_FRONTEND=noninteractive sudo apt-get install postfix -y</pre>