Question

Can't restart ghost on my droplet

  • Posted December 14, 2020
  • Ghost

I am trying to upgrade my Ghost installation from 3.2 to 3.40.1, however after following the instructions here in which I stopped the ghost service, downloaded the latest zip from http://ghost.org/zip/ghost-latest.zip, and unzipped it and replaced my files in the core directory, when I try to restart the service with ghost start I get the following error:

Ghost-CLI commands do not work inside of a git clone, zip download or with Ghost <1.0.0.

I am in /var/www/ghost right now.

Thanks!

Subscribe
Share

It looks like the old update instructions I found are out of date. I’ve been following the instructions here with some success. I removed a ton of junk files from my ghost directory.

Next I ran ghost doctor and was told I had some permission issues and that I should run sudo find ./ ! -path "./versions/*" -type f -exec chmod 664 {} \; so I did. Then I was able to run ghost update successfully, and now I have:

Ghost-CLI version: 1.15.3
Ghost version: 3.40.1 (at /var/www/ghost)

However, I’m now getting the following error when running ghost start:

✖ Starting Ghost: morgz-org
A ProcessError occurred.

Message: EACCES: permission denied, open '/var/www/ghost/config.production.json'
Exit code: EACCES


Debug Information:
    OS: Ubuntu, v18.04.4 LTS
    Node Version: v12.20.0
    Ghost Version: 3.40.1
    Ghost-CLI Version: 1.15.3
    Environment: production
    Command: 'ghost start'

The permissions for config.production.json are: -rw-rw-r-- 1 ghost ghost 798 Jun 24 21:01 config.production.json

The only thing I see that might be an issue is that I’m logged in a ghost-mgr, but the owner of the file is ghost?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi there @morganholland,

Yes indeed this is quite possibly the reason why you are seeing that permissions error.

Have you tried setting the group of the file to the ghost-mgw user instead? You can do that with the following command:

  1. sudo chgrp ghost-mgw config.production.json

Regards, Bobby