Can't seem to add second SSH Key to my droplet

Posted January 8, 2016 3.3k views
Linux BasicsSecurityDigitalOceanLinux Commands


I’ve added a new SSH Key that I got from my second computer into ~/.ssh/authorized_keys, so now online 1 I have to key for my laptop and line 2 the key for my iMac.

I then restarted the service sudo service ssh restart, this worked fine. I’ve even tried rebooting the entire droplet.

Now when i try to SSH in from my iMac ssh root@ip.address, I am prompted for my root’s password which I insert and I get a Permission denied, please try again error.

I’ve also tried:

cat ~/.ssh/ | ssh root@[] "cat >> ~/.ssh/authorized_keys"

However again, i’m prompted to insert my password and again given the permission denied error.

How can I resolve this?

  • Hi! Why a password if you are connected ssh?

  • Try connecting with the-v option, which will output detailed information about the connection as it happens. ssh -v root@x.x.x.x There are many possibilities why you are getting permission denied but by going through the output from -v you should see the problem.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

It could be the key is not being read, but you would need to review the verbose output of your ssh command using the code:

ssh -v root@x.x.x.x - /path/to/key_file

You would want to replace the /path/to/key_file with the actual path to your SSH key file.

If you continue seeing issues with it, you might want to open a ticket with us so we can help look into this further for you.

Hope it helps!
Jason Colyer
DigitalOcean Platform Support Lead