Can't seem to update my droplet

I’m trying to update so I can install docker on my droplet in order to run a backgorund proces

I get to the point where I can’t install packages because I get an error stating the mirror can’t be found.

Earlier today I tried installing zsh and gert the same response.

The droplet is running Ububtu 22.04 Failed to fetch 404 Not Found [IP: 80]

even when I run apt update I get: The repository ‘ kinetic-security Release’ no longer has a Release file.

How do I start getting packages available again?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Site Moderator
Site Moderator badge
November 4, 2023

Heya @info72233eaecf28f33c3f0393d7ab,

The error message “The repository does not have a release file” typically indicates that the repository you are trying to access does not have a version compatible with your current Ubuntu release.

In such cases, I like to do a


Alternatively, you can change the source packages to archive.

# backup your sources file
cp /etc/apt/sources.list /etc/apt/sources.list.bak

# replace the links with the archive address
sudo sed -i -re 's/([a-z]{2}.)?|' /etc/apt/sources.list

But that is a short-term solution.

Site Moderator
Site Moderator badge
November 3, 2023

You can temporarily change your mirror to the official Ubuntu mirror. To do this, create a new file in /etc/apt/sources.list.d/:

  1. sudo nano /etc/apt/sources.list.d/official-ubuntu-mirror.list

Add the following line to use the official Ubuntu mirror:

  1. deb focal main restricted universe multiverse

Save the file and exit the text editor.

The package is available here:

This should sort the error for you.

After making these changes, run apt update again:

  1. sudo apt update

Hope that this helps!

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel