Question

Can't set two domains to direct to separate root folders

Posted February 4, 2018 1.7k views
UbuntuApache

Hello everybody, so basically I have two separate domains, that I’m trying to run on the same droplet, but have both domains navigate to separate root folders, being two separate websites.
I’ve followed this guide to the LETTER: https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-14-04-lts

My sites available folder has the following files: 000-default.conf , cybergamegear.com.conf , default-ssl.conf , and delcontedesigns.com.conf.
So the two domains I’m trying to set up are DelconteDesigns.com (which works) and CyberGameGear.com (which navigates to DelconteDesigns.com currently for some reason, rather than the root folder I want it to.

Here is what my cybergamegear.com.conf looks like:
<VirtualHost *:80>
ServerAdmin jonathandelcontedesigns@gmail.com
ServerName cybergamegear.com
ServerAlias www.cybergamegear.com
DocumentRoot /var/www/cybergamegear.com/publichtml
ErrorLog ${APACHE
LOGDIR}/error.log
CustomLog ${APACHE
LOG_DIR}/access.log combined
</VirtualHost>

The only thing I can imagine is that my 000-default.conf is overriding it?
Here is what that file looks like:

<VirtualHost *:80>

ServerAdmin webmaster@localhost
DocumentRoot /var/www/html


<Directory /var/www/html>
        Options -Indexes +FollowSymLinks +MultiViews
        AllowOverride All
        Require all granted
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

Do I need to delete this file?

3 comments

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

@jnugh
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message.
VirtualHost configuration:
*:80 is a NameVirtualHost
default server 127.0.1.1 (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost 127.0.1.1 (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost cybergamegear.com (etc/apache2/sites-enabled/cybergamegear.com.conf:1)
alias www.cybergamegear.com
port 80 namevhost delcontedesigns.com (/etc/apache2/sites-enabled/delcontedesigns.com.conf:1)
alias www.delcontedesigns.com
ServerRoot: “/etc/apache2”
Main DocumentRoot “/var/www/html”
Main ErrorLog: “/var/log/apache2/error.log”
Mutex watchdog-callback: usingdefaults
Mutex rewrite-map: “using
defaults
Mutex default: dir=”/var/lock/apache2" mechanism=fcntl
Mutex mpm-accept: usingdefaults
PidFile: “/var/run/apache2/apache2.pid”
Define: DUMP
VHOSTS
Define: DUMPRUNCFG
User: name=“www-data” id=33
Group: name=www-data" id=33

  • This looks correct to me. I just notices that your website is served by an nginx, do you use a loadbalancer setup or something similar? It’s probably redirecting everything to delcontedesigns.com.

    • It should be served by apache not nginx. I only set up this for apache, I didn’t touch any nginx settings. I’m not using loadbalancer.
      My thought is maybe it’s something in my networking settings?

        • Did you install nginx? If so: you cant run apache and nginx at the same time on the same ip / port. In this case try: sudo service nginx stop && sudo service apache2 start If it works you should probably uninstall nginx.
        • Is 162.243.5.76 pointing to the correct droplet? Or probably an old droplet running nginx? A floating IP or something pointing to another system?

@jnugh hm.. do you have any idea why disabling nginx would change the way my css/js folders would work?
I’m not sure how to fix that

Submit an Answer