Can't Upload File using Gunicorn

Posted January 23, 2015 4.2k views

I have problems to upload files when use gunicorn in a django app. If i use the django testing server via python runserver, all work fine.

I tried change the owner (to django) and permissions to the folders and nothing change.
How can i fix that or how can i debug with gunicorn?


PD: Sorry my english.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

Solved, was a path problem not permissions.

  • Path problem? How? What path problem? Please tell me more how you got it to work. I might be having same issue now. Will really appreciate

  • when i use the testing server “python runserver” the relative path is diferent than when use gunicorn. The files are uploading to a diferent place… So i change the relative to absolute paths and everything is working.