Question

Cannot access domain/Digital Ocean cannot access server

Posted July 19, 2021 175 views
Linux BasicsNetworking

Hello,

We had a power outage at our office that seemed to reset/corrupt our company router configurations. Since the outage, we have not been able to access one of the domains hosted on the webserver/droplet, as well as the webhook that is stored on the page that transfers are customer orders to our file database. I have configured both ports 80 (HTTP) & 443 (HTTPS) and directed them to the computer IP that hosts the server. After all this, we still cannot access the domain. Is there something on the digital ocean’s end that could have caused this?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hi @devine4b4168d42,

Both events shouldn’t be connected, at least the one from your Droplet’s side. The way you are explaining the issue it seems like there is a Firewall issue somewhere though.

In the reset/corruption of your router, you’ve lost some rules, which most probably means, your Firewall is preventing you to reach the droplet and execute the webhook.

Unless you’ve had your IP changed, the issue shouldn’t be coming from the Droplet. What I’ll recommend for you to check is though to connect to your Droplet and check your /var/log/secure and /var/log/messages to see if any connections from your IP reached the Droplet. I would assume not as said I think the issue is with your local Firewall rather than the Droplet but it’s still worth a try.

Hello, @devine4b4168d42

If the droplet has not been rebooted or if you haven’t done any recent configuration changes, then the issue is most likely not related to the droplet itself.

You can try to access the domain using different networks and devices in order to make sure that the issue is within the office network. Also, you can double-check the router’s options/settings if they’re correct.

Regards,
Alex