Nothing about it works. Does this need vhost files set up?
There is zero documentation from the Digital Ocean side of things. Especially on how to successfully point a domain at it.

Please, please offer documentation that has actually been battle tested by Digital Ocean QA.

This is alarming.

I have zero guidance on how to actually use this LiteSpeed web server correctly with my domains.

Yes, it works out of the box when you go straight to the IP address, but to actually use it - that’s when things start getting frustrating.

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
5 answers

So far this documentation has been helping me.

Why doesn’t your One Click app not open ports 7080 by default?

https://hostadvice.com/how-to/how-to-install-litespeed-web-server-on-an-ubuntu-18-04-vps-or-dedicated-server/

Hi!

When you logged in via SSH, you should have seen a link to the docs. Here is that link again: https://docs.litespeedtech.com/Cloud/wordpress/

If the docs are not addressing a problem you are having, please let us know so that we may update them.

Thanks!
Lisa @ LiteSpeed

  • I’ve the same problem.

    This guide implies that you are able to login to litespeed’s web panel, but it’s not avaiable, even after I enabled port 7080 (which wasn’t opened by default).
    Even while opened, the web panel isn’t available.

    This is definitely NOT a one click setup
    :(

    • Hi,

      Please try command

      netstat -lnp | grep 7080
      

      to check if OLS is binding on 7080 port , if so , then run

      curl -I -XGET https://YOUR_IP:7080 
      

      to see if you can curl it , if curl works but you can’t access it , that means something is blocking it , like your firewall.

      If you are certain firewall is opened , do you see any error message?

      Best regards,

I just came across this problem in my CyberPanel 1-click Droplet. OpenLiteSpeed Web Panel is not available on my droplet at xx.xx.xx.xx:7080…

This post is about how I was able to fix the problem in CyberPanel…

CyberPanel 1-Click install: [https://do.co/2LtWOu2](http://)

I searched the LiteSpeed forum at: https://www.litespeedtech.com/support#gcs for ‘7080’ and found a troubleshooting page for this problem in the wiki at this link:

[https://www.litespeedtech.com/support/wiki/doku.php/litespeed_wiki:troubleshooting:admin-page-unavailable](http://)

So I ssh’d onto my CyberPanel droplet and ran the commands described in the wiki troubleshooting page. I found that port 8090 (CyberPanel) was enabled by the firewall, but not port 7080 (OpenLiteSpeed)…

> iptables -L | grep 8090
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:8090 ctstate NEW

I looked for the file mentioned in the troubleshooting guide (/usr/local/lsws/admin/conf/admin_config.xml), but couldn’t find it…

However I found there is a Firewall Maintenance screen in CyberPanel at:

 CyberPanel > Server > Security > Firewall

I could see an existing entry for port 8090, so I just added an entry for port 7080, which now shows up on the Droplet, and OpenLiteSpeed Web Admin is now available (using the same admin login/pwd I used for CyberPanel):

iptables -L | grep 7080
ACCEPT tcp – anywhere anywhere tcp dpt:7080 ctstate NEW

How would I fix this problem where I was using a 1-click Droplet with only LiteSpeed (ie no CyberPanel)..?

You Solved The Problem.

I didn’t Find the solution even in Litespeed’s Site.

to Enable Port 7080 to access web panel in Litespeed or OpenLitespeed

Goto Your Cyber Panel ( IP:8090 ) and then, Settings - Firewall

Add a New Rule for 7080.

Thank You.

Hello All,

I was having same issue before, and now I fixed…

and then I posted it on their forum.

here is the link to complete procedure.

Example link

Submit an Answer