Question

Cannot access port 8080

I am trying to enable reverse proxying as detailed int this tutorial:

https://www.digitalocean.com/community/tutorials/how-to-use-apache-as-a-reverse-proxy-with-mod_proxy-on-ubuntu-16-04#step-3-—-modifying-the-default-configuration-to-enable-reverse-proxy

When I use curl to access the mini Flask app created in this tutorial on port 8080, I can do it perfectly fine with curl http://127.0.0.1:8080. However, if I use http://mydomain.com:8080, I get a connection refused error.

I have tried disabling ufw with sudo ufw disable. I’ve disabled iptables. I have no firewall running from the web-based control panel. If I run netstat -plan, I can see that 127.0.0.1:8080 is marked as “LISTEN”.

If I use nmap -sS -O 127.0.0.1, I can see that port 8080 is my proxy. However, if I use nmap -sS -O mydomain.com, I do not see 8080 at all.

What am I missing? How do I open 8080?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @fadecomic

Yes port 8080 needs to be added in the Apache configuration file in order to set this up, changing it from the default which is 80. Another thing to have in mind is to make sure the port itself is not closed from the Firewall as well.

Regards, Alex

I figured it out. I had to add ‘Listen 8080’ to my apache conf file.

Where is your DNS Hosted? If you’re using a proxy provider like cloudflare, and have the orange cloud enabled, it will only proxy port 80 and 443 traffic.