Question

cannot access through ssh neither droplet console

I’ve gone through all of this article: https://www.digitalocean.com/community/tutorials/how-to-troubleshoot-ssh-authentication-issues-on-your-droplet And i still have the same issues, also now i can’t even paste the ssh-key into the popup window since it returns an invalid key-type error. Support ticket hasn’t been answered. I’ve done this process with other hosting providers without a problem, this is a simple operation and it’s not working here. I use putty key generator.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

At this point I’m undecided about Puddy, but this is the most relevant post I’ve found. I’m undecided about Puddy, but I simply want to login using the console on my Droplet, but cannot. Before seeing question this I had deleted my Droplet, and created a new one but the problem persists. I’m guessing the problem is a communication problem between the keyboard in the console and my physical keyboard. I say this because I’ve managed to get to the “password reset” prompt, but it acts like it times out or prematurely returns (enter), so it won’t allow me to rest the password. I’ve also tried “ssh root@myipaddress” without success.

Any suggestions are greatly appreciated…

P.S. I have tried pressing the control and shift keys multiple times to clear up “keyboard issues”… It has accepted my manually entered password, but the reset password function does not work.

@guillegallo88

If you add an SSH Key to the DigitalOcean Dashboard after deploying a Droplet, it won’t be on the Droplet and you’d need to add it manually.

The only time SSH Keys are copied over is during initial deployment. If you want to add SSH Keys to the server after a Droplet is deployed, you have to do this manually by adding the key to:

~/.ssh/authorized_keys

… on the Droplet.

If you did add an SSH Key to the DigitalOcean Dashboard and deployed a Droplet afterwards, and it isn’t working, then I would make sure the key is indeed valid and you pasted in the correct key.

When it comes to SSH Keys, when deployed with the Droplet, that’s the only way to login. An invalid key means you’re locked out from the start.

The only types of keys that you should be pasting in via the Dashboard are keys that start with either:

ssh-rsa ....

or

ssh-ed25519 ....

Those are RSA and ED25519 keys (i.e. don’t use DSA keys).

Any other format won’t work, such as the original PuTTy formats.

@guillegallo88

When you used PuTTyGen to generate an SSH key, did you copy the key from the area labeled:

Public key for pasting into OPenSSH authorized_keys file:

… and paste it in to ~/.ssh/authorized_keys? Or did you paste in the PuTTy formatted public key?

The OpenSSH Public SSH Key should start with:

ssh-rsa

If you pasted the public key that PuTTy allows you to save when using “Save public key”, that won’t work as OpenSSH / SSH can’t read PuTTy formatted keys. PuTTy does the conversion in-app when you’re connecting, but you won’t be able to use the PuTTy formatted keys on the server. You’ll have to use the OpenSSH formatted key, otherwise it’ll fail.

So if, in ./ssh/authorized_keys, you pasted something that starts with:

---- BEGIN SSH2 PUBLIC KEY ----

You will end up locking yourself out if password authentication was disabled.

If you can still login using a password, check what was pasted in to authorized_keys and make sure it’s in valid OpenSSH format.