Cannot add A Record to Using Digital Ocean DNS

I am not been able to add an A Record to my domain managed by DNS. It has worked in the past through DigitalOcean where I add a hostname and an external IP so the URL directs to that IP; however, today when I try to fill it out and submit a new A Record I get the error that “Data can’t be blank” and “IP address did not match the IPv4 format (eg.” I am sure that I am entering in a hostname and providing the IP address in the correct format. Is there an issue with DigitalOcean’s web gui? Is there another way for me to add the A record?


@matthewrussell Looks like Firefox works too! Thanks for hint ;)

Failed for me as above on Chrome, tried on Safari and it was OK.

I’m having the same issue. I checked Chrome DevTools and I see that webapp does not send IP address to the server, other fields such as TTL are sent properly.

<3 for this writeup.

I’m having the same issue.

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This issue should be resolved soon. In the meantime here is some more information:

The issue is limited to A and AAAA records. If you need to set one right now you can either:

  1. Use Firefox, Safari, or the API
  2. Use the dropdown instead of manually inputting the target IP

The second method will only work for resources already in your account.

I had a similar error today:

Select resource or enter custom IP cannot be blank

Turned out there was a leading space in my IP address from when I copied and pasted. As soon as I trimmed it, the error went away.

In case this trips up someone else.

This comment has been deleted